The eSeal is available again and all signature services are operational. We will keep monitoring the situation.
Posted Feb 03, 2026 - 16:06 CET
Investigating
The PKisigning eSeal is unavailable. This means all signatures using PKIsigning as signature provider currently cannot be completed. We are investigating the issue.
Posted Feb 03, 2026 - 15:59 CET
This incident affected: Signing engine (Signing service, DigiCert eSeal service).