DigiCert ONE degraded performance

Incident Report for PKIsigning ondertekenplatform

Resolved

Digicert has identified the issue and implemented a fix.
Posted Nov 12, 2025 - 08:35 CET

Update

DigiCert has reported a performance issue within their systems. Because of this, signing a document does not always succeed. Please retry signing the document or try again on a later moment.

More information: https://status.digicert.com/incidents/bfsyy7kzcjx8
Posted Nov 11, 2025 - 09:40 CET

Update

DigiCert is still experiencing issues and a solution has not yet been found. If your signature is urgent, you can try a few times. About half of the signatures seem to fail.
Posted Nov 10, 2025 - 13:11 CET

Investigating

DigiCert is currently experiencing issues with their DigiCert ONE solution. Users with certificates from DigiCert might be unable to sign at the moment.
Posted Nov 10, 2025 - 09:41 CET
This incident affected: Signing engine (DigiCert cloud certificate service).