DigiCert ONE degraded performance

Incident Report for PKIsigning ondertekenplatform

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 10:24 CET

Update

DigiCert has implemented a fix and the issue is resolved.
Posted Nov 13, 2025 - 10:24 CET

Investigating

DigiCert is still experiencing issues with their DigiCert ONE solution. Users with certificates from DigiCert might be unable to sign at the moment. If your signature is urgent, please retry several times.
Posted Nov 12, 2025 - 08:54 CET
This incident affected: Signing engine (DigiCert cloud certificate service).